Intermittent Slow Loading
Incident Report for Flipgrid
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 01:13 UTC
Identified
You may experience intermittent slow loading times when using the Educator Dashboard or in viewing/recording responses. We have identified the issue and are working quickly to resolve.
Posted Nov 19, 2020 - 21:26 UTC
This incident affected: Educator Dashboard, Student/Guest Videos - Web Browser, Student/Guest Videos - iOS app, and Student/Guest Videos - Android App.