Delayed Video Posting
Incident Report for Flip
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 21:57 UTC
Monitoring
You may experience delayed Responses loading or posting in Groups/Topics. No data has been lost and the system should be caught up shortly.
Posted Sep 18, 2020 - 20:11 UTC
This incident affected: Educator Dashboard, Student/Guest Videos - Web Browser, Student/Guest Videos - iOS app, and Student/Guest Videos - Android App.